excel astuce

Formule Excel date du jour automatique

4.8
(24)

Formule Excel date du jour automatique : comment marche la formule AUJOURDHUI() ? Comment adapter cette fonction pour rajouter des jours ou des mois à la date de jour, ou utiliser une condition ? Démonstration à travers un exemple concret.

Dans Excel, il existe la possibilité d’obtenir la date du jour automatique à travers la formule AUJOURDHUI(). En d’autres termes, cette formule permettra d’afficher la date de ce jour sans qu’il soit nécessaire de la changer manuellement, ce qui est très pratique. La date se mettra à jour automatiquement à l’ouverture du document Excel.

La formule AUJOURDHUI() est très utilisée dans Excel pour des tableaux ou des calculs relatifs aux dates. Il est courant de calculer le nombre de jours restant par rapport à une échéance, par exemple dans le cadre du suivi d’un paiement.

Nous allons le voir, la formule permet aussi d’aller plus loin que le simple affichage de la date du jour.

Voici donc décortiquée la formule Excel date du jour automatique AUJOURDHUI().

Voir aussi notre formation Excel en 30 leçons.

Formule Excel date du jour automatique AUJOURDHUI() : explication.

Rappel préalable :

  • dans Excel, chaque date correspond à un nombre précis. La numération commence le 01/01/1900, date qui correspond donc au chiffre 1. Le 02/01/1900 correspond au nombre 2, et ainsi de suite,
  • c’est par la gestion des formats qu’on peut se rendre compte de la correspondance entre les dates et les nombres. Ainsi, le nombre 41998 se transformera en 25/12/2014 si l’on change son format en “Date” (clic droit : format de Cellule, Date).

La formule AUJOURDHUI() (TODAY() en anglais) se construit de manière très simple.

Il suffit de la saisir au sein d’une cellule, sans rien mettre entre les parenthèses :

=AUJOURDHUI()

Cette formule renvoie donc la date de ce jour. Le format de la cellule se met automatiquement en “Date”.

Formule Excel date du jour + 1 jour :

Sur cette base, il est facile de concevoir la formule Excel date du jour + 1 jour :

=AUJOURDHUI()+1

Excel Aujourd’hui + 30 jours :

Pour afficher la date du jour avec un mois de plus, il faut utiliser la formule MOIS.DECALER selon l’exemple suivant :

=MOIS.DECALER(AUJOURDHUI();1) Ici, le chiffre 1 vaut pour un décalage d’un mois.

Attention, il faudra certainement mettre la cellule au format Date pour afficher un résultat lisible.

Fonction Si avec date du jour :

Pour tester la conformité d’une date avec la date du jour, la formule SI peut être utilisée, comme dans l’exemple suivant :

=SI(A12=AUJOURDHUI();”ok”;”pas ok”)

Autrement dit, si la cellule A12 correspond à la date d’aujourd’hui, la mention “ok” doit s’afficher.

Excel date du jour automatique en mois ou année :

Si vous souhaitez afficher la date du jour sous le format mois ou année, voici les formules appropriées :

=MOIS(AUJOURDHUI())

=ANNEE(AUJOURDHUI())

Pour ce qui est de la formule pour les mois, c’est un chiffre qui s’affiche, par exemple 9 pour le mois de septembre. Si vous souhaitez que ce soit le nom du mois qui s’affiche en toutes lettes, il faudra adopter la formule suivante :

=TEXTE(AUJOURDHUI();”mmmm”)

Excel : saisir la date d’aujourd’hui fixe.

Si vous souhaitez saisir la date d’aujourd’hui fixe, c’est-à-dire en empêchant sa mise à jour dans le futur, appuyez simultanément sur les touches CTRL et point-virgule. La date du jour apparaîtra instantanément.

Autre solution, vous pouvez utiliser la formule AUJOURDUI() puis faire un copier-coller en valeur.

Un exemple à télécharger (gratuit).

Cliquez ci-après pour télécharger un exemple concret des formules Excel précédemment décrites :

Extrait du document à télécharger :

formule excel date du jour automatique

Pour aller plus loin.

Voir aussi nos autres articles liés au thème des dates dans Excel :

Vous pouvez noter cet article :

Combien d'étoiles mettriez-vous ?

Note moyenne 4.8 / 5. Nombre de votes : 24

Pas encore de vote ! Soyez le premier.

WordPress Cookie Notice by Real Cookie Banner
%d blogueurs aiment cette page :