excel astuce

Formule Excel Si Alors : comment ça marche ?

4.7
(15)

Formule Excel Si Alors Sinon : explication simple et exemple à télécharger. Voici décortiqué le fonctionnement de la formule Si Excel.

La formule Si est un incontournable d’Excel. Cette formule permet d’évaluer le respect d’une condition, et de renvoyer une valeur si cette condition est respectée, et une autre valeur si elle n’est pas respectée.

La formule Si se construit de la manière suivante :

=SI (Condition à vérifier ; Valeur si condition vérifiée ; Valeur si condition non vérifiée)

Autrement dit, la formule Si peut se décrire de la façon suivante : “si la condition est vérifiée, alors renvoyer telle valeur, sinon renvoyer telle autre valeur”.

C’est la raison pour laquelle on parle de formule Excel “si alors sinon”.

Voyons comment fonctionne la formule Excel Si Alors Sinon, ainsi qu’un exemple simple à télécharger.

Voir aussi notre formation Excel en 30 leçons et exercices.

Formule Excel Si Alors : fonctionnement.

La Formule Excel Si est simple à mettre en oeuvre. Très utile, elle permet de renvoyer une valeur si une condition est vérifiée, et une autre si la condition n’est pas vérifiée.

C’est donc une formule qui permettra de mettre en valeur la conformité ou la non-conformité de certaines données, ou de mettre en évidence certaines données spécifiques.

Exemples d’utilisation de la formule SI :

  • s’il existe un écart entre deux données, alors afficher un message d’erreur, sinon ne rien afficher,
  • si une donnée est inférieure à zéro, alors ne rien afficher, sinon afficher la donnée,
  • si une donnée est supérieure à 100%, alors afficher une alerte, sinon ne rien afficher,
  • etc.

La formule SI comporte trois arguments : la condition à vérifier, la valeur à renvoyer si la condition est vérifiée, et la valeur à renvoyer dans le cas contraire.

Cependant, il est possible de saisir une formule SI avec seulement les deux premiers arguments. Dans ce cas, si la condition n’est pas vérifiée, c’est la valeur FAUX qui s’affichera.

Entrons dans les détails.

Formule Excel si contient texte.

Premier exemple d’utilisation de la formule Excel si alors sinon : si une cellule contient un texte spécifique, alors on souhaite afficher telle valeur, sinon on affichera telle autre valeur.

Par exemple : =SI(A5=”chat”;”ok”;”pas ok”) signifie que si la cellule A5 contient le mot “chat”, alors il faudra afficher la mention “ok” et dans le cas contraire la mention “pas ok”.

On pourrait aussi chercher à renvoyer un message spécifique si la cellule testée comporte un texte quel qu’il soit. La formule sera alors la suivante :

=SI(ESTTEXTE(A5);”ok”;”pas ok”)

Formule Excel Si supérieur ou égal alors.

La formule Excel Si Alors est souvent utilisée pour comparer une donnée par rapport à une autre.

Par exemple : =SI(B11>=A11;”OK”;”Pas OK”) signifie que si la cellule B11 est supérieure ou égale à la cellule A11, alors il faudra afficher la mention “OK” et dans le cas contraire la mention “Pas OK”.

Formule Excel Si inférieur ou égal.

Même principe dans le cas d’un test inférieur ou égal.

Par exemple : =SI(B11<=A11;”OK”;”Pas OK”) signifie que si la cellule B11 est inférieure ou égale à la cellule A11, alors il faudra afficher la mention “OK” et dans le cas contraire la mention “Pas OK”.

Si est différent de.

Si l’on veut tester la non-égalité entre deux valeurs, la formule sera la suivante (exemple) :

=SI(B26<>A26;”OK”;”Pas OK”) signifie que si B26 est différent de A26, alors il faudra afficher la mention “OK” et dans le cas contraire la mention “Pas OK”.

A noter que dans Excel, le signe <> signifie “est différent de”.

Formule Excel si plus grand que et plus petit que.

Ici, on cherche à établir une formule Si avec deux conditions : on veut tester une valeur par rapport à une deuxième valeur (dont on veut vérifier qu’elle est plus petite), et par rapport à une troisième valeur (dont on veut vérifier qu’elle est plus grande).

Si les deux conditions sont respectées en même temps, alors on affichera une valeur, et dans le cas contraire une autre valeur.

Pour cela, on utilisera la formule suivante (exemple) :

=SI(ET(A32>A33;A32<A34);”OK”;”Pas OK”) signifie que si A32 est à la fois supérieur à A33 et inférieur à A34, alors il faudra afficher la mention “OK” et dans le cas contraire la mention “Pas OK”.

Formule Si Excel avec 2 conditions ou critères.

Même chose que ci-dessus.

Formule Si Excel avec 3 conditions ou critères (ou plus).

Les choses se corsent un peu si l’on souhaite utiliser la formule Si avec 3 conditions.

Il s’agira alors d’imbriquer plusieurs formules Si, comme dans l’exemple qui suit :

=SI(ET(A37=A38;A37=A39);SI(A37=A40;”OK”;”Pas OK”);”Pas OK”) signifie que si A37 est égal à A38 et A39, et aussi à A40, alors il faudra afficher la mention “OK” et dans le cas contraire la mention “Pas OK”.

Un exemple concret à télécharger.

Cliquez ci-après pour télécharger des exemples de formules Excel Si Alors, c’est gratuit, immédiat et sans inscription :

Extrait du document à télécharger :

formule excel si alors exemple

D’autres formules et astuces Excel.

Le site sur lequel vous naviguez actuellement regorge de formules Excel expliquées et d’astuces pour tableur.

Cliquez ici pour y accéder.

Vous pouvez noter cet article :

Combien d'étoiles mettriez-vous ?

Note moyenne 4.7 / 5. Nombre de votes : 15

Pas encore de vote ! Soyez le premier.

WordPress Cookie Notice by Real Cookie Banner